DanTModules New Releases Thread [v2.4.0]

Whoo, Hoo!

Fixed all currently known bugs for V2, so ready to go for release unless new bugs are found.

Hopefully this means I can either add some new features to the modules, or maybe even finish off some of the experimental modules I’ve been working on for the official release.

In the mean time the bug free V2 windows build has be posted.


Bug free. Brave words!

I can’t extract it on my Win10, I get a message “Unrecognized archive format”

You shouldn’t need to extract it, it should download as the vcvplugin format, you just put it in your plugins directory and start VCV Rack 2 and it will extract it for you

thats exactly what I did,
and I get the message when I want to run v2 from my mingw64 with the “make run” command,
then I get the “Unrecognized archive format” message in mingw64

Are you building Rack from source? If so are you using the correct version 2.git.042a9ce0

I haven’t built rack from source, I am just using the build @Vortico provided here

It’s working here with the prebuilt 042a9ce0

I just did a new build of Rack version 2.git.042a9ce0
and I still get the same error

Do other vcvplugin files get extracted?

Have you tried using the prebuilt version?

I’m not really sure how I can help out, it seems that the issue stems from the building of Rack currently.

How are you downloading the file from github? Maybe there is something going on there.

Maybe you could try opening the archive directly, ie: reversing this part of the makefile tar -c $(SLUG) | zstd -$(ZSTD_COMPRESSION_LEVEL) -o "$(SLUG)"-"$(VERSION)"-$(ARCH_OS_NAME).vcvplugin

I just did a new build of Rack version 2.git.042a9ce0

Did you also download the new 2.git.042a9ce0 version of the SDK? My understanding is that both the app and the plugin need to be built against the same version

I found the issue:
I downloaded it from your github manual page via

  • right mouse click on “DanTModules-2.3.4-win.vcvplugin (built for 2.git.042a9ce0)”
  • “save target under …”
  • then I get a “DanTModules-2.3.4-win.vcvplugin” file with just 144kb

but when I

so maybe the linking on the github page is somehow wrong?

1 Like

Ok good to hear you got it working, yes it sounds like a github thing, when i click on the link it shows me the file in the repo, and then there is a download button. If anyone knows of a better way to link to a repo file in markdown i’ll happily change it.

I think making a “release” is the “right” way, yes?

1 Like

Well maybe for a repo where you build the code, but this is just my manual site and a single preview page with links to files that I have added to the repo, does a release make sense in that context?

Oh, good Q. It does let you add arbitrary binaries, so probably good? But yes, a little different for you.

I’ve not made a release in github before, if you could give me a little pointer in the right direction I’ll give it a try

I won’t be at my main computer for a while (work meetings). I think you just click on the”releases” tab. I’d ask the google.

Ah no worries, yes it is that simple, but I had the releases tab turned off :woozy_face:

Ok, I have now created a github release with the latest vcvplugin and will update releases in future to avoid confusion

1 Like

New release that includes the Wavulike Auto-Duck feature

1 Like