Can't Compile Plugin - "recipe for target 'plugin.dll' failed"

I was trying to compile a plugin for the first time. And I followed the tutorial but the compilation has failed. Here’s the full log:

I use msys64 on Windows 10.

Hi. There is a long list of errors. It’s impossible to help without looking at the source code.

one possible problem is that you have a space in the path (New folder). msys2 doesn’t like that.

Hello again,
I tried to remove any spaces in the path but I got the same error.
And I’m using the default source code with no changes, if needed I can upload it.

People can only make guesses unless you post the full build output including commands you ran.

I downloaded msys64, added the and run the following commands:

pacman -Syu
pacman -Su git wget make tar unzip zip mingw-w64-x86_64-gcc mingw-w64-x86_64-gdb mingw-w64-x86_64-cmake autoconf automake mingw-w64-x86_64-libtool mingw-w64-x86_64-jq python

I didn’t get a jq exectutable, so I downloaded it from:

To create the module I ran the following commands:

python createplugin MyPlugin

I changed the RACK_DIR variable from the generated plugin.json from:

RACK_DIR ?= ../..


RACK_DIR ?= ..

Then I added the panel vector image to the res folder and ran:
python createmodule MyPlugin res\MyModule.svg src\MyModule.cpp

Are you using the Mingw64 shell, not the MSYS shell? mingw-w64-x86_64-jq should provide jq, so you probably missed “launch the MinGW 64-bit shell” in the instructions.

I’m using window’s command prompt

There’s your problem. Be sure to follow the instructions in for building plugins.