can´t find modul - very annoying bug

hello, i have a very annoying problem with vcv rack as plugin. when loading a project in bitwig, it can always happen that the vcv plugin does not find modules, even though they are in the library. this is really a very annoying problem. what can be the reason? best regards

bitwig 4.3.4 mac osx 10.14

there, again and again the same problem. Apparently not only I have this problem, but also other users for a while! If you’re asking $149 for a plugin, shouldn’t the developer take care of this problem at some point???

What did support say?

Support are very helpful. Reach out.

In my case Ive found that limiting myself to a single instance of vcv per project (and using multiple outs) seems to reduce the frequency of the bug. I’m not sure why.

maybe the problem is not related to VCV but to Bitwig,
maybe Bitwig is keeping VCV from scanning the modules?
(I’m on win, so I can’t test it myself)

To hunt for the bug you could install Reaper
and try to use VCV inside Reaper
and see if the same problem occurs (Reaper is free to try).

I’m using Bitwig 4.3.4 with Rack Pro 2.1.2 in OSX 12.4, with quite a few instances of Rack and I’m not getting this problem.

Seems like an odd one (possibly related to permissions?) and I can understand the frustration but VCV support is the place to raise your issue. This is just a user forum.

1 Like

When you do submit a proper support request, maybe leave out the parts about the entitlement you feel because you paid money and that the dev’s are stupid or lazy.

1 Like

I tried cardinal for a while and the problem didn’t occur there! then i decided to invest the money, precisely because of the large library. so you can say I support the project. only that this problem has already occurred. I have now written to the support of vcv and bitwig. I suspect it could be a problem with sandboxing in bitwig.

plugin engine changed to bitwig. plugin permissions changed. didn’t do anything. sometimes the plugin loads the modules, sometimes not. above all, there are always very different modules. never the same.

Did you contact the VCV support?

yes, there was an answer right away. unfortunately that didn’t help either.

from vcv support:

Can I please confirm this error still occurs if you go to the System Preferences of your Mac - go to the Security & Privacy page, then select the Privacy panel, then go to the Full Disk Access permissions and check that both Bitwig and VCV Rack 2 Pro have been given access. You can do this under the Files and Folders permissions instead if you prefer.

We have had another user report this issue, so we are looking into it and hope to have a fix for you soon, but it would be good to rule out the most common cause of this kind of issue.

an answer came very quickly. they take care of the bug. i hope…vcv is really a nice thing

not made with vcv but real modular hardware and for free! :wink:

Quick question: what sandboxing settings are you using for VCV in Bitwig? Is it per instance, or by manufacturer?

I’m now trying out running vcv in by manufacturer mode. I wonder if per instance permissions is why I was having problems with multiple rack instances, but not with single instances.

One issue that I still have regardless of whether I run only 1 instance or multiple is that the VST version of rack usually shows up to date plugins as requiring update. But if my patches are loading I don’t care about that.

I’m Sandboxing By Plugin.

It doesn’t matter whether it’s the manufacturer or another setting. the error still exists.

despite extensive support help, the problem could not be solved for me. (thanks to paul from support)

the problem must somehow be related to bitwig and a non-functioning full disc access.

I tried it in ableton, there are no problems at all. all modules are loaded properly with the project.

paul wrote me that i have to give full disc access to bitwig and vcvrack in the security and privacy settings. I did, but still doesn’t work.

does anyone else have an idea?

it is due to some setting for bitwig.

cheers

have you reached out to Bigwig support? If Ableton woks fine, then maybe they are the ones that need to sort this out, as it does not appear a VCV Rack issue given that…

yes, once. the support said it had to be a problem with vcv. which is obviously not the case. so it’s my turn.

one consideration of mine would be to update my os. i have a mac pro 5.1 (2010), i have to update it to the current os with a patch.

is this recommended? I don’t have money for a new mac right now.

cheers

not sure how far the 2010 macpro will update, but anything from last 3 OS releases should be fine, if supported. So some googling may help establishing which is latest MacOS you can install on that machine.

However that will only help if Bigwig has issues with what you have installed now. However, stranger things have happened. So back up and see which OS to go test to see if it makes things work…

after I gave my mac pro 5.1 (2010) a clean big sur installation (really nice os), everything is now working as it should. no modules that can no longer be found in the vcv plugin. must be some setting or installation that has caused problems. i’m happy now. thanks for the support and your tips. stan

3 Likes