build toolchain not working for Linux target?

Has anyone gotten the official build toolchain to work with Ununtu? Mine will build mac and win, but barfs on Linux, apparently because my gcc is called gcc, not x86_64-ubuntu16.04-linux-gnu-gcc

I’m running Ubuntu 20 - does one need to turn Ubuntu 16 to use the build toolchain for a linux build?

@cschol - are you still involved in this?

Never mind. We can continue this on Github.

Full error is in the github issue I created (but forgot to paste here)

No, am not using docker, I am running the toolcahin “natively” in an Ubuntu VM. Where should I find the gcc built for 16? Funny, I didn’t even think of this. Of course I knew it was building clang for mac stuff…

Rack 2.1.0 builds and runs fine on my Ububtu 20.04

EDIT: Ah, I see you’re in the toolchain, nevermind then :slight_smile:

yes, me too. It’s just the build toolchain that’s the problem. I can build linux rack and plugins the “normal way” just fine.

solved, I think it was pilot error (I ran out of disk space during the build and it got left in a strange state).