Blamsoft: download failed

Howdy all. I am just getting VCVR set up (again) and am having issues with the Blamsoft plugins. The module manager page indicates that I have them, and when I click update plugins I see messages about them being installed, but they aren’t in my plugins folder nor anywhere else on the computer. I have tried toggling off the button that says I already have them, logged out and back in multiple times and rebooted several times… I am disabled firewall and security software temporarily.

Here’s what the log file says:

[4.623 info src/plugin.cpp:199] Downloading plugin Blamsoft-XFXF35 0.6.0 win
[5.019 warn src/plugin.cpp:204] Plugin Blamsoft-XFXF35 download was unsuccessful

Not sure how to proceed, any ideas?

just try to download it again
(delete the zip package and the folder if you have it)

I have tried to download the plugins many times over, as well as confirmed that neither the folders or zip files are on my computer. VCV is throwing an error (see above) whenever I click Update Plugins. I need to know what’s causing that error. It only happens on Blamsoft plugins, no others. I will contact their tech support.

1 Like

Still no luck with these plugins and there’s no contact info for Blamsoft anywhere. Can someone on Windows post their blamsoft plugin folders somewhere that I can pull them down? Would be much appreciated! Thanks

Having the same issue here. Everything other than XFXWave fails for me.

1 Like

Should be fixed now.


Yes! Update downloaded the plugins and they are working fine now. Thank you!

1 Like

I have tried downloading XFX Wave multiple times since updating VCV to the latest version. Each time the download reaches between 50-60% then says download complete, does the forced exit of VCV, and when I restart the app, it is still in the update queue. At which point, when I click update, the same result each time.

Since this involves updating/downloading from the VCV Library, email with a description of the issue.