Best practices for VST VCV Rack 2

I just bought the VCV Rack 2 - both because of how I believe author of such amazing software and community has to get paid, as well as I wanted to use the VST plugins. :slight_smile:

Is there any manual / best practices for the VST version specifically?

I got my way around using MIDI and CC in Ableton - works like a charm, no problem! - but I’m wondering if there’s some way of mapping VST “parameters” (not sure if it’s called this way) to CV. Use case - I lovel Ableton’s M4L LFOs and other plug-ins that I can automate and are an inherent part of my workflow. I’d like to be able to map to some of CVs inside the VCV Rack VST. I can go around with midi CC messages, but only partially - like Ableton for example “consumes” all MIDI on the first plug-in instance and workarounds are quite ugly (routing through more channels sends/returns).

Is there some recommended workflow for such an use-case? The best-best way would be to map some knobs directly, but I can understand if that’s difficult to implement or even goes against the modular ideas - then a 2nd good option would be to have a “VST params” module with CV outputs.

Thanks again for the great work over the years!


You can map knobs directly to Ableton automation lanes if that helps?

On the VCV device in Ableton, click on configure, then touch a knob or whatever in VCV and you can now have an automation lane for it.

Not sure about mapping a Max4Live LFO to VCV but let us know if you figure it out :slight_smile:

Once you’ve a “configured” a parameter in the device as Steve has mentioned you should be able to just map the LFO as you normally would with Ableton devices.

1 Like

Yes it does work! I missed that, thanks. :slight_smile: Now we need a convenience multiple-knobs-to-CVs module with renamable parameters so we can combine those with other CVs (or is there one?).

im having problems using automation in ableton, everytime i turn a knob or push a slider it appear in the ableton automation lane but as soon as i release the mouse it toggles back to reserved and whatever was there is removed from the dropdown list

If it works the same way as in Bitwig, what might work is to click (without changing the value) the control you’d like to automate - then it isn’t replaced by “Reserved”

1 Like

that worked. weird.

i had the same problem. it works you just gotta use mouse parkour and click the right thing at the right time . i did it a couples times but i didnt know what made it work or fail ¯_(ツ)_/¯