Azure Pipelines for Github allows build of plugin

Hey great - and yeah it’s wonderful right? Always have the latest binary available and never do a pull request that doesn’t build. Glad it worked for you. (I also have to chmod +x my scripts but git should keep that status once you do it in the repo - or maybe you have to add them chmodded)

I added Artifacts handling and publishing now - works great.

Thank you!

2 Likes

Wow, thanks for this tutorial @baconpaul !

I almost have it running for https://github.com/mhetrick/hetrickcv. It’s failing when running scripts/release-notes.sh:

[command]/bin/bash --noprofile --norc /home/vsts/work/_temp/c816734f-bc72-42fa-9671-018677c637f0.sh

/home/vsts/work/_temp/c816734f-bc72-42fa-9671-018677c637f0.sh: line 1: scripts/release-notes.sh: Permission denied

##[error]Bash exited with code '126'.

I saw @stoermelder mention using chmod to modify the file permissions, but doing so on my local machine doesn’t mark the file as modified for git. Any ideas?

Yeah if you don’t check it in 755 it has the wrong perms. Right before that script runs in the azure pipeline just chmod it (so like put the chmod command in azurepipelines.yml)

Chmod u+x scripts/release notes.sh

Or if you want explicitly source it so

. Scripts/releasenote.sh

On my phone sorry for the autocorrect boogers but you get the idea. Just chmod it in the azure pipeline right before it runs.

Good luck and glad it works for you!!

Edit; I found this https://medium.com/@akash1233/change-file-permissions-when-working-with-git-repos-on-windows-ea22e34d5cee which shows you how to change permissions in the repo from windows. That should work but I haven’t tried it

1 Like

Yes!!! That worked. I changed the permissions via git.

Thanks again for sharing the knowledge with us. I’ve been wanting to learn this CI stuff for Unfiltered Audio since we spend so much time wrangling builds.

Great!

Azure Pipelines has started failing to build for me on Linux, and I’m pretty sure I haven’t changed anything. Here’s the error:

g++ -std=c++11 -Wsuggest-override  -fPIC -I/home/vsts/work/_temp/Rack-SDK/include -I/home/vsts/work/_temp/Rack-SDK/dep/include -MMD -MP -g -O3 -march=nocona -funsafe-math-optimizations -Wall -Wextra -Wno-unused-parameter -DARCH_LIN -c -o build/src/Follower.cpp.o src/Follower.cpp
In file included from /home/vsts/work/_temp/Rack-SDK/include/window.hpp:8:0,
                 from /home/vsts/work/_temp/Rack-SDK/include/rack.hpp:11,
                 from src/EntrianRack.hpp:6,
                 from src/Follower.cpp:16:
/home/vsts/work/_temp/Rack-SDK/dep/include/GL/glew.h:1205:24: fatal error: GL/glu.h: No such file or directory

The internet tells me I need to install libglu-dev or similar, but I didn’t need to do that previously, and I’m not sure it’s even possible in an Azure Pipeline. I’m using imageName: 'ubuntu-16.04'.

Is anyone else seeing this? Any workarounds? (Paging @baconpaul…)

Same error here…

I haven’t run my rack pipeline in a while - I’ve been heads down in surge proper - but we do a set of apt-gets in our pipeline. I would recommend an apt-get install libglu-dev or what not as a first attempt to fix this.

Here’s the point in our surge synth release pipeline where we do our apt gets.

3 Likes

Thanks, adding sudo apt-get install libglu-dev fixed it!

2 Likes

Thanks, Paul!

(Now I feel foolish for not just trying it - I just assumed that sudo wouldn’t be a thing in an Azure pipeline.)

1 Like

I encountered an issue with implementing the pipeline. It seems there’s a bug in azure where the Personnal Access Token isn’t recognized as such, which prevent uploading the release.

Error: Invalid GitHub service connection scheme: Token. Only OAuth and GitHub personal access token connections are allowed.

If anyone encounter this issue, I followed the workaround there : https://ljvmiranda921.github.io/notebook/2019/12/28/workaround-azure-github-pat/

And it worked !

Thanks again to @baconpaul for providing the guidelines and the script :sunny:

1 Like