Audio-8 doesn't see ASIO devices

Hi everyone, after looking on several old version related posts, I still can’t use my sound card with ASIO.(The option is not even available)

I’m using Community Edition2.git219bbaf1 with a x-32 sound card on WIN10.

I’m guessing that’s the Behringer X32 X-USB ? I don’t have one, but the behringer Uphoria UMC1820 works fine.

Perhaps reinstall latest firmware and USB drivers ?

Does it work with other ASIO software - like Reaper (fully functional 60-day evaluation)?

https://www.behringer.com/product.html?modelCode=P0AZP

Yep it works on 1.6 too I just Tested with builded version of rack2, and it works fine.

Ah, The version of track v2 you build yourself doesn’t include ASIO unless you set an option when “make dep” - It’s a licensing issue.

1 Like

Ok thank you :slight_smile: i’ll use the sdk then :wink:

RTAUDIO_ASIO=1 make dep

1 Like

Ok so I make dep Rack dir, after set this value right ?

yes VCV Manual - Building, except for

make dep

changes to

RTAUDIO_ASIO=1 make dep

1 Like

hey jens.peter, thank you for your solution, i am far from programmer, how can i change it, or better where? all the best … marian

It’s explained how to build here. But it builds without ASIO on windows. If you need that - replace make dep in that page with RTAUDIO_ASIO=1 make dep. I can’t explain it better.

But I’m curious, why do you need to compile Rack 2 ?

You can get the installers here, much easier. https://vcvrack.com/Rack#get

Good morning! Actually i dont understand in which Environment i should do the change, is it a browser app, a program, how do i save the changes, i only know arduini basics :sweat_smile: Cheers!

Sure you’re not just joking - on the top of the page i just linked

" Install MSYS2 and launch the MinGW 64-bit shell from the Start menu, not the default MSYS shell . Update the package manager itself … "

You probably don’t need to compile Rack yourself … just use the installer from vcvrack.com

Okay, thank you!

I stick to installer from vcv rack

‘make dep’ takes a long time, so I wouldn’t want to build all the dependencies again, just RTAudio. Is there any way to do that? Right now make just says “Nothing to be done for ‘dep’”.

I always re make everything. Did you use -j4 or something to speed it up? Sarcastic answer: if you can’t figure it out you shouldn’t try it.

Gotta admit, I’m not an expert on git submodules and make files. But Visual Studio would recognize the changed option and rebuild only the project it applies to. Also cleaning only one project is not a problem. :wink:

So I ended up cleaning and remaking all deps. Had to do it twice because of errors in zstd (???), but now it works.

1 Like