A Couple of Tips for VCV Rack Performance on Older MacBooks

Hi There!

I wanted to use VCV Rack for quite a long time but whenever I loaded it up on my 2015 MacBook Pro it would immediately start to heat up and the fans would get extremely loud. Not only that, I would hear horrible glitches whenever I would move my mouse or adjust a parameter and the whole experience was quite choppy. However if I minimised the Rack window it would run smoothly in the background and the fans would slow down. I’ve decided to give it one last try and spent a few hours on forums going through posts that were a couple of years old and used older Rack versions. Eventually I was able to find some tips that were scattered throughout different forums, and they proved to be very useful! I’m not a computer savvy person, but I’ll try my best and summarise the steps that improved my Rack experience dramatically. So if you’re running into the same problems maybe some of these steps will help you!

  1. Lock the VCV Rack frame-rate to 24-30 fps by opening your finder and putting settings-v1.json in the search bar. Open the settings-v1.json file with text editor and change the frameRateLimit to your desired fps.

  2. Run VCV Rack in low resolution mode by going to Applications, right clicking on Rack and selecting Get Info. Tick the Open in Low Resolution box.

  3. Turn off other CPU/GPU consuming apps. I usually keep my Google Drive Backup turned on in the background and surprisingly after turning it off, the performance dramatically improved.

After these steps my CPU temperature went from ~80 to ~68 and fans are mostly silent. Haven’t had a glitchy sound or laggy experience since!

It’s possible that these steps are completely obvious, but I do hope that it will be useful to at least some newcomers! If anyone has any more tips that could improve Rack performance on Macs please comment below!

P.S There is still a problem that I still run into every time which is very high CPU usage of any Audio Interface modules. For example the CPU timer for AUDIO-8 while it’s idle shows only 0.7% of resources used. As soon as the audio device is activated the usage rockets to around 70%-80%. If anyone knows how to fix this please leat me know!

3 Likes

that’s actually what you have left, even tho it’s scary red. it’s non-obvious that it means the opposite of what it means on every other module. hopefully @Vortico will implement the suggestion here:

3 Likes

This user, for example. Silly me, I thought measurements were taken in use percentage, and not inversely.

I also found that limiting the frame rate on my MacBook Pro greatly improved my experience, and visually it still looks fine to me.

another MacBook Pro helper is using an external GPU. if you’re on Mojave, and your laptop supports an eGPU, you can specify using the external GPU for Rack - helps quite a bit.

Turning off Wi-Fi saves some CPU as well.